Decryption error?

The place for "I can't figure out how to..." questions.
Post Reply
kaladin
User
Posts: 1
Joined: Sun Aug 24, 2014 8:09 am
Are you a spambot?: no

Decryption error?

Post by kaladin » Sun Aug 24, 2014 8:15 am

Hi,
I'm using owncloud 7.0.1 and the music application (https://github.com/owncloud/music), not sure which getid3 version is used..
When getid3 scans my mp3s, I get the following errors:

Debug music imported entities - artist: 3, album: 3, track: 18 2014-08-18T15:31:17+00:00
Debug music addTrackIfNotExist - added - ID: 18 2014-08-18T15:31:17+00:00
Debug music addAlbumIfNotExist - exists - ID: 3 2014-08-18T15:31:17+00:00
Debug music addArtistIfNotExist - exists - ID: 3 2014-08-18T15:31:17+00:00
Debug music extracted metadata - artist: , album: , title: 03 pigs Three Different Ones.mp3, track#: , year: , mimetype: audio/mpeg, fileId: , this->userId: stef, userId: stef 2014-08-18T15:31:17+00:00
Debug music fallback metadata extraction - removed code 2014-08-18T15:31:17+00:00
Debug music getID3 error message: Caught exception: Encryption library: Decryption (symmetric) of content failed 2014-08-18T15:31:17+00:00
Debug music getID3 error occured 2014-08-18T15:31:17+00:00
Debug music getID3 error message: error parsing "APIC" (309 bytes into the ID3v2.3 tag). (ERROR: $frame_size (13771) > strlen($framedata) (null)). 2014-08-18T15:31:17+00:00
Debug music getID3 error occured 2014-08-18T15:31:17+00:00
Error PHP openssl_decrypt(): Failed to base64 decode the input at /var/www/clients/client1/web1/web/apps/files_encryption/lib/crypt.php#241

getID cannot parse my mp3 files, the openssl_decrypt seems related, see this error popping up with all MP3s I have tested with. I tried several of them and they don't work either..

Any idea what's going on?

James Heinrich
getID3() v1 developer
Posts: 1416
Joined: Fri May 04, 2001 4:00 pm
Are you a spambot?: no
Location: Northern Ontario, Canada
Contact:

Re: Decryption error?

Post by James Heinrich » Sun Aug 24, 2014 12:21 pm

Whatever those encryption-related errors are, they seem unrelated to getID3 itself. I would suggest talking to the owncloud developers.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest