Unknown QuickTime atom type

The place for "I can't figure out how to..." questions.
Post Reply
Zwurbel
User
Posts: 1
Joined: Sun Sep 21, 2014 6:32 pm
Are you a spambot?: no

Unknown QuickTime atom type

Post by Zwurbel » Sun Sep 21, 2014 9:01 pm

Hi,

a buddy of mine and me have been messing around with getID3. The code works for him, but doesn't for me. We've got getID3 set up exactly the same way and are using the same sample files (a 6 second 375kb .mp4). We also use the same (and current) getID3 version.

When I var_dump the result of the analyze function, the first noticable thing is a warning:

Code: Select all

[warning] => Array ( [0] => Unknown QuickTime atom type: "dat" (64 61 74) at offset 160 [1] => Unknown QuickTime atom type: "????" (ff 0f 7f ff) at offset 380164 )
After that, the code eventually just cuts to gibberish altogether .. sample:

Code: Select all

ip_ratio=1.40 aq=1:1.00�Te�� �"����!�@F8E��?�y~��Q)
I can't access any video information like resolution or playtime.

Any ideas on how to fix this?

Thanks in advance
Zwurbel

James Heinrich
getID3() v1 developer
Posts: 1411
Joined: Fri May 04, 2001 4:00 pm
Are you a spambot?: no
Location: Northern Ontario, Canada
Contact:

Re: Unknown QuickTime atom type

Post by James Heinrich » Mon Sep 29, 2014 3:38 pm

If you browse to the sample file using demo/demo.browse.php in your webbrowser, does it show info as expected?

Can you provide a link to the sample file in question, please (by PM or email is fine if you wish).

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest