PHP7 support

The place for "I can't figure out how to..." questions.
Post Reply
zzan
User
Posts: 1
Joined: Sun Jul 05, 2015 3:26 pm
Are you a spambot?: no

PHP7 support

Post by zzan » Sun Jul 05, 2015 3:35 pm

I have a setup that has the Apache/2.4.12 (VC14,Win32) and PHP/7.0.0alpha2. I am getting an error when trying to get data from mp4 file:
Fatal error: Switch statements may only contain one default clause in \getid3\module.audio-video.quicktime.php on line 432
I can get the data when running; Apache/2.4.12 (VC11, Win32) and PHP/5.6.9.

PHP 7 is expected to go final before the end of 2015, will you have a updated version of getid3 for PHP7?
https://wiki.php.net/rfc/php7timeline
http://windows.php.net/qa/
http://www.apachelounge.com/download/

James Heinrich
getID3() v1 developer
Posts: 1411
Joined: Fri May 04, 2001 4:00 pm
Are you a spambot?: no
Location: Northern Ontario, Canada
Contact:

Re: PHP7 support

Post by James Heinrich » Sun Jul 05, 2015 5:43 pm

Nothing special about PHP7 in that case, just an as-yet-undiscovered bug, but it didn't generate a PHP warning before PHP7. I have removed the duplicate "default:" clause in
https://github.com/JamesHeinrich/getID3 ... 6aae7c1ec2

I have no particular plans to test against PHP7 anytime soon, but if you do then please continue to report any issues you discover.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests