Error in converting real, id3v1 tags

The place for "I can't figure out how to..." questions.
Post Reply
bilal
User
Posts: 4
Joined: Mon Oct 16, 2006 2:07 am

Error in converting real, id3v1 tags

Post by bilal » Mon Oct 16, 2006 2:15 am

Hello!

When i edit Real format songs tags after the tags edit i get a Chunk error and when we play the song in any song player like real player or jet audio the song is start but when we forwerd the song then the song is stop, i allready edit 1300 songs tags but now i notice this error please any one help i am really in a big trouble... :(:(:(

bilal
User
Posts: 4
Joined: Mon Oct 16, 2006 2:07 am

Post by bilal » Tue Oct 17, 2006 12:10 pm

No any one here for help please help me i am really in a big trouble...

James Heinrich
getID3() v1 developer
Posts: 1432
Joined: Fri May 04, 2001 4:00 pm
Are you a spambot?: no
Location: Northern Ontario, Canada
Contact:

Post by James Heinrich » Tue Oct 17, 2006 12:30 pm

It could be that something in the Real tag writing process is invalidating the seek index block. Does the file play ok if you just let it run all the way through the file and not try and jump forward or backwards? If so, then that's the case.

It seems the cause of this is that the INDX block stores absolute file offsets for it index (not relative to the start of the audio stream, because the tag data is at the beginning of the file), and the Real format is not robust enough to skip to the next valid block (like in MP3, for example).

I think this issue should only occur if the written Real tag is longer than the original one. The quick solution is to limit Real tag writing to less-than-or-equal-to length of previous Real tag. Better fix would be to rewrite INDX blocks, but I don't know enough about their structure to be comfortable doing that.

edit: Shortening the Real tag back to its original length should fix the seek problems, but figuring out what the original length is and rewriting the tag accordingly would probably be a fairly manual process at this point.

bilal
User
Posts: 4
Joined: Mon Oct 16, 2006 2:07 am

Post by bilal » Tue Oct 17, 2006 3:19 pm

Thanks for your responce! yes after edit the tag the song is play but when we try to forwerd it its stop playing...

I try all the thing even if i just click on edit tags and then in next page didnt change any thing and click on "Save Changes" then its also give error i just want to change the "Artist" fields the new tag have 10 letter and old have 17 letters.

I also try to change the tags with original once's but still the same problem.

Please tell me any solution i am very thankfull.

Allan Hansen
getID3() v2 developer
Posts: 445
Joined: Sun May 04, 2003 2:22 pm
Location: Holmegaard, Denmark

Post by Allan Hansen » Thu Nov 16, 2006 10:05 am

Real writing support will be removed in 1.7.8.

Developers please help fix this module. The broken module is available in version 1.7.7.

Post Reply