Page 1 of 1

[1.7.7] Another iconv() support question

Posted: Wed Oct 18, 2006 12:38 pm
by wietze
Hello dear getid3 developers,

I am currently using the getid library to index my own music collection and put it into a database. It has been working fine until some recent additions to my collection. When I run a script that runs through my directorytree to analyze all the files, it breaks on a certain file with the message:

PHP does not have iconv() support - cannot convert from to UTF-8

and the script stops. I also tried to view the file using the supplied demo, but the demo shows me the same message.

I have been using the search function on this forum before asking my question, and I found the fix for 1.7.0 (in a zip). I am currently using the 1.7.7 version of getid3.

I was wondering if there is any way to keep the getid3 from dying, maybe the hotfix for 1.7.0 is still applicable?


Kind regards,
Wietze Spijkerman

Posted: Wed Oct 18, 2006 12:47 pm
by Allan Hansen
The 1.7.0 hotfix was added to 1.7.1 and is still there as of 1.7.7.

The usual solution to iconv errors is to add iconv support in PHP. This is rather simple under windows, but takes a little effort under UN*X.

However this iconv error is not usual. It complains about not being able to convert from a "empty string" charset. This is clearly a bug in getID3(). Could you possible host or e-mail the file in question? ah at artemis dot dk.

Posted: Wed Oct 18, 2006 1:46 pm
by Allan Hansen
This is a bug in the ID3v2 module related to 'LINK' frames.

A quick fix that stops getID3() from dying:

getid3.lib.php

line 953, insert

if (!$in_charset) {
return $string;
}

Posted: Wed Oct 18, 2006 3:42 pm
by wietze
Thanks Allan,

your responsetime and support are remarkable, in case I come across anything else, I will surely put it down here.

Kudos,
Wietze Spijkerman

Posted: Fri Nov 10, 2006 1:07 pm
by Allan Hansen
Fixed in 1.7.8 CVS