2.0.0-b4 and 1.7.8-b1 tag image detection

Locked
andig
User
Posts: 12
Joined: Fri Oct 12, 2007 12:55 pm

2.0.0-b4 and 1.7.8-b1 tag image detection

Post by andig » Fri Oct 12, 2007 1:40 pm

Both 2.0 and 1.7.8 have problems detecting images in id3v2 tags. Both come to different results regarding presense of an image, neither detects all images correctly. I'd be happy to submit the file for inspection of required.

Thanks,
Andi

andig
User
Posts: 12
Joined: Fri Oct 12, 2007 12:55 pm

Post by andig » Fri Oct 12, 2007 3:04 pm

I've verified that 2.0.0 doesn't find the APIC frame on the files in question although text editor shows that it's present. Also MediaMonkey shows the image just fine.

James Heinrich
getID3() v1 developer
Posts: 1476
Joined: Fri May 04, 2001 4:00 pm
Are you a spambot?: no
Location: Northern Ontario, Canada
Contact:

Post by James Heinrich » Fri Oct 12, 2007 11:40 pm

You can submit a small test file to info@getid3.org
Preferred is a link to a file (of any size) hosted somewhere, or if not a small (100kB or smaller) sample file showing the problem(s).

andig
User
Posts: 12
Joined: Fri Oct 12, 2007 12:55 pm

Post by andig » Sat Oct 13, 2007 12:04 pm

Sent link by email- thanks! Would be happy to do any testing.

James Heinrich
getID3() v1 developer
Posts: 1476
Joined: Fri May 04, 2001 4:00 pm
Are you a spambot?: no
Location: Northern Ontario, Canada
Contact:

Post by James Heinrich » Sat Oct 13, 2007 5:34 pm

A quick test here of v1.7.8b1 shows the APIC just fine.

James Heinrich
getID3() v1 developer
Posts: 1476
Joined: Fri May 04, 2001 4:00 pm
Are you a spambot?: no
Location: Northern Ontario, Canada
Contact:

Post by James Heinrich » Sat Oct 13, 2007 5:42 pm

James Heinrich wrote:A quick test here of v1.7.8b1 shows the APIC just fine.
Sorry, the testfile you submitted does not contain an APIC frame, no embedded picture I could find. However, the other test file (for the false-Lyrics3-detected thread) you submitted does contain an embedded APIC that detects just fine here.

andig
User
Posts: 12
Joined: Fri Oct 12, 2007 12:55 pm

Post by andig » Sat Oct 13, 2007 5:57 pm

You are right as I'm now realizing- sorry for the false alarm. I got misguided by MM which actually showed me an image- duh.

Thanks for your support!

Locked