Page 1 of 1

[1.9.8] Minimum PHP 5.3

Posted: Wed May 14, 2014 12:50 am
by Pernod
In 1.9.8 I see you changed the minimum required PHP to 5.3. Do any changes actually require 5.3 yet? I have a few users that are still using 5.2.x for various reasons so will be unable to update.

Re: [1.9.8] Minimum PHP 5.3

Posted: Wed May 14, 2014 12:55 am
by James Heinrich
At least one change did require 5.3.x, but offhand I couldn't tell you what it is. Quite possibly something obscure, I'd have to go digging in all the changes on Github to see what it was. I suspect 5.2 or 5.1 are probably still fine for the most part.

Re: [1.9.8] Minimum PHP 5.3

Posted: Tue Nov 11, 2014 3:58 pm
by James Heinrich
PHP function sys_get_temp_dir is only present in PHP v5.2.1+, a workaround added for older versions in https://github.com/JamesHeinrich/getID3 ... 95998b5c82