demos does not work

The place for "I can't figure out how to..." questions.
Post Reply
thowa
User
Posts: 1
Joined: Sat Jan 28, 2006 2:17 pm

demos does not work

Post by thowa » Sat Jan 28, 2006 2:36 pm

Hi All,

I have just started to explore the getID3()-Famework.
I run the the demo.browse.php and got the following errormessage
Warning: main(../getid/getid3.php) [function.main]: failed to open stream: No such file or directory in C:\apachefriends\xampp\htdocs\MusicDB\include\getid3\demos\demo.browse.php on line 52

Fatal error: main() [function.require]: Failed opening required '../getid/getid3.php' (include_path='.;c:\apachefriends\xampp\php\pear\') in C:\apachefriends\xampp\htdocs\MusicDB\include\getid3\demos\demo.browse.php on line 52
I have changed the require_once in line 52 to

Code: Select all

require_once('C:\apachefriends\xampp\htdocs\MusicDB\include\getid3\getid3.php');
Now the demo.browse is running, but no ID3-tags are displayed. the following error is displayed for each mp3-file
"C:apachefriendsxampphtdocsMusicDBincludegetid3..helperapps" cannot be defined as GETID3_HELPERAPPSDIR because it does not exist
(Note: the missing back-slashes are no typos from me...)

I have modified the line 114 of getid3.php from

Code: Select all

			$helperappsdir = GETID3_INCLUDEPATH.'..'.GETID3_OS_DIRSLASH.'helperapps'; // must not have any space in this path
to

Code: Select all

			$helperappsdir = GETID3_INCLUDEPATH.'..'.GETID3_OS_DIRSLASH.'helperapps'; // must not have any space in this path
#			$helperappsdir = GETID3_INCLUDEPATH.GETID3_OS_DIRSLASH.'helperapps'; // must not have any space in this path
Then it works.


If I click on any "edit tags" I receive the following error again
Warning: main(../getid3/getid3.php) [function.main]: failed to open stream: No such file or directory in C:\apachefriends\xampp\htdocs\MusicDB\include\getid3\demos\demo.write.php on line 20

Fatal error: main() [function.require]: Failed opening required '../getid3/getid3.php' (include_path='.;c:\apachefriends\xampp\php\pear\') in C:\apachefriends\xampp\htdocs\MusicDB\include\getid3\demos\demo.write.php on line 20

What is the problem, that all the

Code: Select all

require_once('../getid/getid3.php');
are not properly handled?


As you might have noticed, I'm using:
XAMPP 1.4.11 with PHP 5.0.3
Windows XP SP2

Thanks for any hint,
Thorsten

Post Reply