Getid3 is not working at all...

The place for "I can't figure out how to..." questions.
Post Reply
autonic
User
Posts: 3
Joined: Fri Oct 06, 2006 7:25 pm

Getid3 is not working at all...

Post by autonic » Fri Oct 06, 2006 7:36 pm

Evening...

i've downloaded the getid3class to my webserver and unzipped.
First I head off to the demos-folder, i thougt that it would be a good place to start learing the class from...

I added the variable:

$filename = hello.mp3

and hit refresh, but the demo.basic.php isn't printing anything at all....
and then I get this "Aha" moment and I start thinking that the mp3file maybe needs " " or ' ' to contain it, so now i'm trying:

$filename = 'hello.mp3';

And voila! I finally get some output from the class.
The title, songname and so forth reveals itself on the screen :)

So far, so good.

But now i first want to add some <br> tags to get the data in a neat and orderly fashion.
I hit refresh again and nothing happens, the screen is blank once again.

So i remove the <br> from the sourcecode and hit refresh once again, but the screen is still blank!

Ok... so i remove all of the getid3 files from my webserver and upload a fresh set of them (directly from the zipfile) again.
I enter the demo.basic.php and set the variable to:

$filename = 'hello.mp3';

EXACTLY like i did the first time (when I had my "Aha" moment), and nothing else on the webserver has changed.

But it wont echo the data from the file. No errors, no nothing.
And everything is EXACTLY like the way they were when i got it to work the first time.

The only file i've ever edited is the demo.basic.php so don't mind bothering about wether i've edited some other files during my first try...

It just wont work!
what the Fuck could I be doing wrong?

Allan Hansen
getID3() v2 developer
Posts: 445
Joined: Sun May 04, 2003 2:22 pm
Location: Holmegaard, Denmark

Post by Allan Hansen » Fri Oct 06, 2006 8:27 pm

Forum rules 1 through 3 also applies to users using Fuck in posts.

autonic
User
Posts: 3
Joined: Fri Oct 06, 2006 7:25 pm

Post by autonic » Fri Oct 06, 2006 8:38 pm

wow, that was a friendly and welcoming post :)

you managed to call me an idiot without using the actual word :lol:

Allan Hansen
getID3() v2 developer
Posts: 445
Joined: Sun May 04, 2003 2:22 pm
Location: Holmegaard, Denmark

Post by Allan Hansen » Fri Oct 06, 2006 8:46 pm

autonic wrote:wow, that was a friendly and welcoming post :)

you managed to call me an idiot without using the actual word :lol:
You are welcome.

However I did in no way call you an idiot or anything similar. I simply stated, that you are wasting your own and our time, since you will not get an answer in here. This forum is not a general PHP forum, some basic PHP skills are required (does not involve AHA experiences with quotes around strings).

Post Reply