Page 1 of 1

Iphone 6 Picture GPS coordinates missing

Posted: Mon Aug 08, 2016 4:41 pm
by rosglue
This is a really strange problem that just suddenly cropped up. getID3 always extracted out my iphone picture gps coordinates successfully, but now it doesn't for some reason. All other exif data is there except the gps data. I verified that the gps coordinates are actually their using "exif" on the commandline. Included is the getID3 printout. Has anyone else been having this problem? The videos work fine still.

Re: Iphone 6 Picture GPS coordinates missing

Posted: Mon Aug 08, 2016 5:22 pm
by James Heinrich
A sample file would be useful.

Re: Iphone 6 Picture GPS coordinates missing

Posted: Mon Aug 08, 2016 5:41 pm
by rosglue
My bad, i meant to upload but the photo was over the limit.
https://www.dropbox.com/s/4svm10sx4apph3t/4.jpeg?dl=0

Re: Iphone 6 Picture GPS coordinates missing

Posted: Mon Aug 08, 2016 6:02 pm
by James Heinrich
Seems to be working fine: 37.42910278,-122.07375278

What version of getID3 and PHP are you using? Have either of them changed recently?
Can you please attach your output from demo.browse for this file?

Re: Iphone 6 Picture GPS coordinates missing

Posted: Mon Aug 08, 2016 6:10 pm
by rosglue
Snap, I just realized I recently updated php- mines running phpv5.5.9. Is that the cause of my problems?

Re: Iphone 6 Picture GPS coordinates missing

Posted: Mon Aug 08, 2016 6:39 pm
by James Heinrich
I suspect it is related to your PHP installation, but I'm not exactly sure how. First of all check that EXIF support is enabled (I believe it is), but I'm puzzled why it's returning only some of the data. For example, look at [jpg][exif][FILE][SectionsFound] -- I see "ANY_TAG, IFD0, THUMBNAIL, EXIF, GPS" but you only see "ANY_TAG, IFD0, EXIF". And even within the sections you do see (e.g. COMPUTED, EXIF, IFD0) you're not getting all the values that I am. But you're getting some values, which is what puzzles me.

Re: Iphone 6 Picture GPS coordinates missing

Posted: Mon Aug 08, 2016 9:32 pm
by rosglue
I'm pretty sure it's just that the new php versions break it. I've recompiled on fresh images several different php versions (5.5.9 and 5.6.24 with the --enable-exif ./config flag) and none of them worked. I recompiled using 5.4.7 and it worked. Maybe php changed their exif parsing functions?

EDIT: yeah it's the php library exif functions that don't work anymore. I tried the same thing with exif_read_data(...) and the newer versions don't have the gps data, while the older versions do.
rosglue
User

Posts: 4
Joined: Mon Aug 08, 2016 4:36 pm